Jump to content

Britney: I love getaways with Sam...he means the world to me - please stay safe everyone!!!


Recommended Posts

  • Slayer changed the title to Britney: I love getaways with Sam...he means the world to me - please stay safe everyone!!!
  • Replies 65
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Cassie be like:

yesss she is paying homage to the glory cover    Queen of backbends 

Posted Images

  • Super Moderators
18 minutes ago, nwonder said:

yesss she is paying homage to the glory cover 
 

Queen of backbends 

:makeitrain_britney_blush_headphones_omg_wow_happy:

While promoting her unreleased Abroad :bop_beyonce_dancing_yes_Yas_cheer_party_glasses:

  • Love 2
  • Haha 6

 I am a performer. I am a Mom. I am funny. I am your friend! I am Britney Jean

Link to post
1 minute ago, Broccoli Spears said:

Queen of not being able to wear a face mask correctly. :jl_jamie_lynn_awkward_cringe_eek:

She's outside and clearly not near anyone she doesn't know... it's admirable she's even covering part of her face at all when she didn't need to in that scenario.

  • Love 2
  • Like 6

he used to sing me sweet melodies ♫

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

We noticed you're using an ad blocker  :badthoughts_gun_kris_genner_thinking_debating:

Thanks for visiting Exhale! Your support is greatly appreciated 💜  

Exhale survives through advertising revenue. Please, disable your ad block extension to help us and continue browsing Exhale. 🙏

I've disabled ad block